Tag Archives: bug

MATLAB 2014a Bug, BLAS loading error: dlopen: cannot load any more object with static TLS

This article is Just for future reference.

I faced a MATLAB bug: BLAS loading error: dlopen: cannot load any more object with static TLS.

My MATLAB version is 2014a running on Ubuntu 14.04.01

Here is the workaround and what you only need to do is

1. Download the attached file from the following link.

2. Replace libiomp5.so file at /R2014a/sys/os/glnxa64 (Ubuntu)

http://de.mathworks.com/support/bugreports/961964

Cheers,

 

 

BCM4331 bluetooth bug.

Hello,
I’m currently running on a MacBook Pro 8,3, 11.10-amd64 Ubuntu, kernel 3.0.0-14-generic.
I was able to use this guide to compile and use the B43 driver for my 4331 WiFi card. WiFi generally works great, though I’ll have times when it’ll appear connected to the network but isn’t able to get any internet access, but that’s not what this issue is about.
The main issue is that I’ve determined that the driver/card severely interferes with and inhibits in many cases the use of Bluetooth. While b43 is loaded, I can’t find any Bluetooth device with hcitool scan or hidd –search, but when I rmmod it, I’m able to find my devices. If you’d like me to demonstrate, I’d be happy to.
The main problems are as follows:

  1. Bluetooth is completely unable to detect devices for pairing when b43 is running in the kernel, no exceptions.
  2. More often than not, my Motorola S305 headphones connect to my computer, then disconnect, then reconnect, then disconnect, all without entering A2DP or HFS mode. My headphones never actually get connected in a way that’s usable most of the time.
  3. Audio playback and high-bandwidth uses of Bluetooth are terribly inconsistent, choppy, and sounds terrible.

All of these problem go away if I rmmod b43.
So, going forward I’d like to help in any way I can to get this issue resolved. Can anyone show me how I can completely uninstall b43 and start again from scratch? Are these issues known? What version of broadcom-wl, compat-wireless, and b43-fwcutter should I be compiling against?